Results 1 to 4 of 4

Thread: Problem with Programming Icom IC-F80DS

  1. #1
    Bartosz No Longer Registered

    Default Problem with Programming Icom IC-F80DS

    Hi guys,

    I just purchased used icom-f80ds p25 radio from ebay and I step into the commercial radios world.
    My happiness stopped just straight after I couldn't get it
    it talking to my pc. I got the programming cable also from ebay, I
    believe it`s Chinese knock off but it should still do the job. The model number
    is RPC-1966-U, its based on prolific chip and it has 3 pin on the connector.
    Once I got it I connected everything, installed right drivers, radio turned on,
    cs-70 opened, and... Nothing! I keep getting No answer from transceiver. I tried
    trick with pushing p0 button but it didn't work. I tried it running on different
    pc, changing com ports, speeds etc. Nothing. Any suggestions? I asked the guy,
    who sold me the radio, what he used, he said that he used the ribless cable with rs232 serial, the
    cable he have has 4 pins so maybe that is the problem? My Firmware version is 2.1u.

    Thanks!


  2. #2
    Join Date
    Nov 22, 2013
    Location
    Wisconsin
    Posts
    27
    Thanks
    1
    Thanked 3 Times in 2 Posts
    Country: United States

    Default

    The message "no answer from transceiver" is a indication that the cable is being recognized by the software but it is not putting the radio into programing mode. Are you able to read or get the transceiver information from the radio? Typically the programing cable for the IC-F70/80 will have 9 pins.

  3. #3
    Bartosz No Longer Registered

    Default

    No I was not able to get anything. Once I tried upgrading the firmware and radio was just turning in self off. Anyway I already got the refund on cable, I just wait for rs232 version which has 4 pins. The original 9pin opc cable is too expensive for me and it is almost the triple the price I paid for the radio.

  4. #4
    Bartosz No Longer Registered

    Default

    OK I received a new cable, now with broken pin ahh this quality cables. Anyway I manage to fix and now cable is able to read and write to radio so this problem is solved. But it seems like a I have an old firmware and it shows me that my radio is mdc not compatible. Does anybody have a new firmware for this radio?