• If posting about a radio issue: Include the HOST, DSP and UCM/secure firmware versions, flashcode and CPS version you're using along with the operating system info. This is critical information.

Flash Upgrade XTL5000 problem

Status
G

gef

Not Registered
Hi.
Have been doing some firmware upgrades from R12.xx.xx to R16.xx.xx on XTL5000's ...Have been supplied
the USB key for this and use to work fine. Now of late the process is halting not long
after it starts and displays message "Unable to create intstance of Encaten Component"
I wait for a while for something to happen then close it. I reopen and try the flashupgrade again this time getting "Error Code 0x80040154: Class not registered"
I then click ok on that then get the "Unable to create intstance of Encaten Component". Can anyone flash some light on this problem I am having . Have done dozens of these in the past with no problem .. Have changed comps and USB keys.
 

Alpha

T¹ ÆS Ø - Moderator, CS Forums $upporter
Staff member
CS Forums $upporter
Joined
Feb 12, 2012
Messages
2,755
encatencomponent.dll is a DLL in the Windows directory that gets installed when you install CPS. It sounds like your install has become corrupted, possibly due to a disk or filesystem error. First, run CHKDSK (ScanDisk) on the affected machine. If that doesn't help, try re-installing CPS. If that doesn't work, un-install CPS and re-install. If that doesn't work, take computer out back and shoot in the CPU. Seriously, if you get to that point and it still is shot, your Windows install is probably corrupt. Back off your data and re-install Windows, then CPS.
 

Bigfella237

Ø Tactical OTAR Slayer
Joined
May 16, 2012
Messages
474
I agree with Alpha, it sounds like the dll file is no longer registered with your Windows OS for some reason, you could try registering the dll manually, Windows provides a tool for doing this although this still may not fix your issues...

Goto Start Menu > Run and type "regsvr32.exe /i encatencomponent.dll" (without the quotation marks)

If this fails then follow Alpha's suggestions and start reinstalling...
 
OP
G

gef

Not Registered
eggcellant .. thanks fellas I could not find the "regsvr32.exe /i encatencomponent.dll" so unistalled my cps and reinstalled and seems to have rectified my problem ..
now I can do my work instead of pushing it off to Moto ..
cheers all
 

Bigfella237

Ø Tactical OTAR Slayer
Joined
May 16, 2012
Messages
474
No problem... maybe I should have explained it more clearly but I guess it all worked out in the end, glad to hear it's all working once more.
 
OP
G

gef

Not Registered
I must have installed my latest CPS over a recent one .. as you would with the older cps's ...
so just wiped my old cps and re-installed with the new one.
anyhow tks agn.
 
Status