Garbage pi-star security problem

Mars

Prolific Contributor
CS Forums $upporter
Joined
Dec 21, 2011
Messages
4,987
I noticed Pi-Star created its own Wi-Fi AP (in the clear, no encryption) , regardless of what I had the web GUI settings configured as. I even created a PSK (after I noticed the "clear" AP) and it would not secure itself.

This garbage Pi-Star shit caused a security problem on my network by allowing unauthorized persons to utilize my internet. The only way to kill this shit is to add the following line to /boot/config.txt:

dtoverlay=disable-wifi

Reboot.

After you install this Pi-Star garbage, be secure to do an AP scan and see if you're also running a wide open AP in the clear for all to see/use. Hams are dumb as fuck for leaving this type of "default" configuration. Just because a majority of hams are retarded and incapable of grasping security (dumbest default settings possible) doesn't justify this type of nonsense.
 

TESTMODE

Prolific Contributor
CS Forums $upporter
Joined
Jul 19, 2019
Messages
123
For a distro that attempts to lock everything down as much as possible between the ro fs and absolutely insane firewall rules etc, that is pretty fucking dumb.

I understand it probably helps people with ease of setup or whatever, but it would be trivial for the thing to create a random AP name at boot with a common key like the pi-star account uses or something.
 

g4tuz

Regular Member
Joined
Feb 24, 2020
Messages
12
In Pi-Star, configuration - auto-ap off works for me. A re-boot is required after saving setting. Pi-star 4.1.4
 

AMBE+2

Contributing Member
CS Forums $upporter
Joined
Mar 5, 2019
Messages
39
I disable the wifi radio and use the USB to enthernet adapter. I continually laugh at the morons in the Pi-Star / P25 forum and facebook pages and the utterly woeful stupidity when comes to ANYTHING IP related and the in ability to have a clue as to what they are doing. IDIOTS
 

WQNV648

Prolific Contributor
Joined
Jun 8, 2012
Messages
262
The first time I tried using Pi-Star, I ran into some issue with their firewall setup, so I decided to disable iptables to rule out an issue, found out the hard way their software doesn’t like that...