• If posting about a radio issue: Include the HOST, DSP and UCM/secure firmware versions, flashcode and CPS version you're using along with the operating system info. This is critical information.

Motorola BOS II Error 128

bigredrobotninja

Regular Member
Joined
Jul 17, 2019
Messages
14
Just picked up a Motorola BOS II (which I think is just a re-badged Cadex C7400) along with some adapters for XTS3000/5000 batteries. I've been able to analyze a bunch of old EF Johnson (587-5100-470) and Motorola (NNTN6034) batteries with good results.

However, I've got one EF Johnson battery (model 587-5100-364) that's different from the others, and I can't seem to get it to work. It seems to charge OK on my EF Johnson charger and an IMPRES charger that I have, but when I put it on the BOS II it gives me error code 128 and flashes "SOFT" on the screen. According to the manual, error code 128 is "UNABLE TO CLAMP CHARGE VOLTAGE". I've tried reducing the charging rate, and I've tried charging it and discharging it a couple of times on my other chargers, but I still get that same error. Anybody have any ideas about what this error means and if it's possible to revive this battery?