NX5800 Bootloop & Solution

axel

Prolific Contributor
CS Forums $upporter
Joined
Sep 3, 2015
Messages
507
Hi all,

Had my dual brick NX5700/5800 setup die on me tonight. Radios worked fine yesterday, left the truck overnight, this afternoon the radios were bootlooping on me. See the video below:

(pay no attention to that custom boot screen)

I narrowed it down to the 5800 brick. Hooked it up on the messy bench to verify it wasn't a power issue, same result:


I spoke with my dealer and a couple people on the NX5000 users group on FB. Was getting pretty terrified that I was sitting on a $1k paperweight. Then my dealer (Evans Mitchell from FL - fantastic guy) pulled out his notebook and realized he had the same issue with a 5900. To fix it, he had pulled the "TIB" off the brick and cleaned & reseated the ribbon cable interconnect. I was skeptical, but I tried it out.

The result? Perfectly working now! It's bizzare that just sitting overnight was enough to mess up the contacts on the ribbon cable. Maybe thermal expansion from the hot-cold cycles with how chilly it's been here recently. Either way, it's working like a champ now!

This is one to file away in the "stupid tricks that could save your ass" folder.
 

Forts

Prolific Contributor
CS Forums $upporter
Joined
Aug 6, 2012
Messages
835
Wow that's a sharp screen on those, very nice!
 

com501

Prolific Contributor
CS Forums $upporter
Joined
Jan 18, 2013
Messages
2,785
But why the weird jewish guy with the radio as your boot screen?
 

David

Contributing Member
CS Forums $upporter
Joined
May 5, 2015
Messages
60
"Pay no attention to the boot screen" Everyone (including myself) digging the boot screen.
 

cyrus

Trailer Park Superintendent
Staff member
CS Forums $upporter
Joined
Jan 5, 2012
Messages
945
OP
axel

axel

Prolific Contributor
CS Forums $upporter
Joined
Sep 3, 2015
Messages
507
It's a running joke in my radio friend group - a completely random and contextless photo of a jewish guy with a radio has become one of our favorite images.