• If posting about a radio issue: Include the HOST, DSP and UCM/secure firmware versions, flashcode and CPS version you're using along with the operating system info. This is critical information.

XTL1500 900MHz dead control head ?

M274

Regular Member
Joined
Feb 21, 2021
Messages
6
I made a mistake and purchased cheap used (questionable) XTL1500 900MHz P25 (HAM ready) on ebay and probably ended up with a brick door stop.
One beep after power on, nothing on display. Rear acc. cable is ok, power to ignition ok. CPS will not read, can't open port. After asking seller, he mentioned failed flash upgrade to 20.05.07 so I'm assuming the control head is stuck, or mismatched/ wrong firmware.
Because of flash on sticker is 00804... I'm suspecting he was trying to flash it for P25 or cram in XTL2500 firmware.
I'll have rear RS-232 cable in couple of days to try to get in that way. Only tried front USB cable so far.
Any thoughts? Should I start looking for working control head?
It is more of an learning experiment at this point, not mission critical.
Thanks

Model: M28WRS9W1AN
Flashport: 0080480024107
 

axel

Prolific Contributor
CS Forums $upporter
Joined
Sep 3, 2015
Messages
518
If you can get it to at least stay powered on, you might be able to force it into flashzap mode via the rear serial connection (AT#FZAP=1). Retrying the failed upgrade again could possibly revive it.
 
OP
M

M274

Regular Member
Joined
Feb 21, 2021
Messages
6
If you can get it to at least stay powered on, you might be able to force it into flashzap mode via the rear serial connection (AT#FZAP=1). Retrying the failed upgrade again could possibly revive it.
Thanks. I will definitely try that as soon as the cable comes in.
 

wiredwrx

Prolific Contributor
CS Forums $upporter
Joined
Mar 20, 2014
Messages
648
I have found that in most instances, when power is properly applied, the radio will boot to some stage. If you have an ammeter, you can watch the unit boot, and see if it remains "on." If it remains on, you should be able to access the radio with a serial connection.

Also, have you considered disputing the purchase through ebay?
 

Number 6

T¹ ÆS Ø - Site Host
Staff member
CS Forums $upporter
Joined
Feb 28, 2012
Messages
2,003
Try reading / writing from the rear. If you can, upgrade the FW and see if the head upgrades. If not, synch the head and try the FW upgrade again. Of course since the radio was hit with depot you could have a corrupt codeplug as well.
 
OP
M

M274

Regular Member
Joined
Feb 21, 2021
Messages
6
Thanks all for responding.
Update:
Rear RS232 came in, I can read the brick no problem now, here is what's in it:
Codeplug: 0022
Firmware: R20.50.09
Tuning: R01:00:03
Bootloader: R07:00:00
DSP: R19:50:01
UCM: Unknown
Nautilus: R04:00:05
Flashcode: 508044-801004-7

The control head display is dark, no LEDs illuminate even whe turning power ON. Windows and CPS doesn't recognize it via the USB cable connected to the CH.
If I try to synchronize CH via the rear RS232 it fails. Trying to do control head upgrade via the rear connector I get message "Radio Failed to Bootstrap - check all cables "
I will inspect all the wiring again.
Would RS232 front cable work better?
Is it possible to even address the CH via rear RS232?
I'm still suspecting the CH is not powering on for some reason.
 

Number 6

T¹ ÆS Ø - Site Host
Staff member
CS Forums $upporter
Joined
Feb 28, 2012
Messages
2,003
It could be a host of problems but checking power to the head is a good starting point. This thread might give you some ideas:

 

sarguy1941

Contributing Member
CS Forums $upporter
Joined
Dec 29, 2019
Messages
72
Id swap the head first if you have one. I threw a pile of those away recently.
 
OP
M

M274

Regular Member
Joined
Feb 21, 2021
Messages
6
It could be a host of problems but checking power to the head is a good starting point. This thread might give you some ideas:

Thanks for the link. Good read. I'll probably continue exploring. This is good way to learn.

Id swap the head first if you have one. I threw a pile of those away recently.
Shoot, I wish you still had one laying around somewhere. They are hard to find. We are still using XTL2500, XTL5000 and XTS radios on my SAR team. Can't afford to switch to APX yet. Surviving on donations and grants. You probably know how that goes.
 

Number 6

T¹ ÆS Ø - Site Host
Staff member
CS Forums $upporter
Joined
Feb 28, 2012
Messages
2,003
Try a head from an XTL2500 as a test.
 

Number 6

T¹ ÆS Ø - Site Host
Staff member
CS Forums $upporter
Joined
Feb 28, 2012
Messages
2,003
Perhaps but it won't matter when trying to see if it displays anything. It will either work or you might get "remote maintenance" or "FL01/90" displayed. At least you will be able to conduct a power up test.
 

sarguy1941

Contributing Member
CS Forums $upporter
Joined
Dec 29, 2019
Messages
72
I'll dig around this weekend and see if I have any more in boxes. Thought someone had one on the forum for sale at one point also.
 

radioman2013

Prolific Contributor
Joined
May 1, 2012
Messages
202
I wonder, did the radio come with the MX head. If so it might not like the 2500 or 5000 firmware. when I upgraded my 1500 to 5000 I put an O-5 on it with no problem.