• If posting about a radio issue: Include the HOST, DSP and UCM/secure firmware versions, flashcode and CPS version you're using along with the operating system info. This is critical information.

XTS IMPRES MUC not charging MOTOTRBO batteries

Status

ndp

Prolific Contributor
CS Forums $upporter
Joined
Mar 12, 2019
Messages
239
Pretty much the title. Got a excellent deal on a WPLN4121BR multi-unit charger. Looks like date code is January 2017, version 3.40 on the sticker. Won't charge any of the TRBO batteries we have. Based on my searches it should be all set with the FW version.

Ideas welcome.
 

medic550

Prolific Contributor
CS Forums $upporter
Joined
Feb 26, 2012
Messages
183
Which model trbo? 6500 series wont charge in those adapters. only 7550 series batteries.

There is a slight enough difference that the contacts on 6500 series battery cant make contact.
 
OP
ndp

ndp

Prolific Contributor
CS Forums $upporter
Joined
Mar 12, 2019
Messages
239
Yep, that would appear to be the issue. How annoying! Leave it to Moto...
 

medic550

Prolific Contributor
CS Forums $upporter
Joined
Feb 26, 2012
Messages
183
If you have a large fleet of 6500 I would look for a TRBO impres rack on ebay. They will handle both 6500/7500. I snagged one for 40 dollars and it had vertex standard branded on it. I have an IMPRES firmware flasher so i updated to latest firmware and charge all my trbo in that.
 
OP
ndp

ndp

Prolific Contributor
CS Forums $upporter
Joined
Mar 12, 2019
Messages
239
Good to know. I'll keep my eye out for one of those.
 

MTS2000DES

Prolific Contributor
CS Forums $upporter
Joined
Mar 14, 2012
Messages
450
IIRC 3.9 or higher is required to support the TURDBO batteries.
 
OP
ndp

ndp

Prolific Contributor
CS Forums $upporter
Joined
Mar 12, 2019
Messages
239
Interesting. I'll have to read the charger, perhaps it's been upgraded. Tried it out with some friend's 7550 IMPRES batteries and it seems all set.
 
Status